Manager desktop crashes when I click on Expense Claims

Manager Desktop Version: 20.2.86

Everything else seems to work fine, but when I click on Expense Claims tab, the application closes.

What edition(Desktop, Cloud, Server) and what platform are you using?

If you set up a new business and customise for Expense Claims, does the same error happen?

Edition: Desktop edition
Platform: MacOS Catalina
Version: 20.2.86

Tried again by setting up a new business. It doesn’t crash for new business.
For existing business though, it’s crashing.

Using a backup copy of your existing business, try removing the Expense Claims tab, backup and import again and reinstate the Expense Claims tab to see if that cures the problem or at least points to some problem in your Expense Claim data.

Followed these steps using a backup:

  1. Removed each individual expense by using employees tab
  2. Removed Expense Claims tab
  3. Added Expense Claims tab

Still crashing after these steps.

Hmm, seems like a problem with your business file. I don’t think Just removing the tab deletes the records - I think you would have to compact the data file which might remove after disabling the Expense Claim tab which might remove the records causing the problem

Tried this too. Still crashing. Any way I can access crash logs, maybe that gives some clue.

Thanks so much for your help and patience, much appreciated :slight_smile:

Presumably, you have tried downloading and installing Manager again - although this seems to be a data problem so beyond the scope of my expertise

have you tried creating a backup of your business and then importing the new file in Manager?

Yes, already tried re-installing, didn’t work.

Tried creating a backup and re-importing too, didn’t work either.

I found the crash logs, attaching it for reference for anyone who can help on this.

I have looked into this using the exact setup you described, @shobhit, for several businesses. I cannot duplicate the problem. I conclude you have a corrupted data file. So every time you copy and re-import it, you see the problem again. But a new business shows no issue. Re-installing Manager is also of no help, because the new installation calls the same corrupted data file.

If you have older backups, try importing them until you get to one that works. Whatever was added between that backup and a newer one that exhibits the problem will contain the corruption. It will be a matter of rebuilding the workable file to bring it up to date. Since you only see the problem with Expense Claims, you should be able to use batch operations between the most recent data file and the older, workable one to simplify the task.

@Tut @Joe91 I figured out the problem, and feel it is an issue introduced due to this feature release:

Listing the steps which led to the issue:

  1. Created some new Control Account for employees of different department - product, engineering, sales, etc
  2. Updated each employee to reflect the correct departmental Control Account
  3. After these steps, the Expense Claims tab started to crash whenever I try to open it. Do note that there were many expense claims already existing.

Listing the steps which resolved the issue:

  1. Remove the departmental Control Account from every employee.

Hope this provides some context to replicate the issue at your end and then solve it. I really liked the Control Account feature for employees and want to continue using it.

Thanks again for the continued help and patience :slight_smile:

@shobhit, I have been able to duplicate this bug. It occurs only when all employees are assigned to
a custom control account for employees. If at least one employee is assigned to the default Employee clearing account, the program does not crash when clicking the Expense Claims tab.

I am moving this topic to the bugs category.

Fixed in the latest version (20.2.87)

Wow, that was super fast!

Verified at my end too, no more crashes. Thanks so much.