Incorrect Average cost calculation on Payment or Purchase Invoice with Tax

Helo @lubos, I think there’s a bug on Inventory Item Average Cost calculation when Tax is involved.

I tried to buy an inventory item, “Logitech BCC950” via Purchase Invoice, with “Amounts are tax inclusive” is checked. Here is how I fill the form.


.
.
manager.io is able to calculate the Tax Amount correctly as 345,545.45. Here is the resulting Purchase Invoice.

.
.
But somehow manager.io incorrectly calculated the Inventory Item Average Cost as 3,510,000.00. The expected Average Cost should be around 3,545,455.00 right? which is 3,900,000.00 minus 345,545.00 (the Tax). Here is the screenshot I took in the Inventory Items page.

.
.
.

I tried another approach, by buying the item directly from the Receipt & Payment tab. Here is how I fill the Payment form, also “Amounts are tax inclusive” is checked. The Unit Price is 3,900,000.00.

.

Here, manager.io calculated Tax as 390,000.00, the Tax should be around 345,454.00 right? Here is the resulting Payment slip view

.

And then I tried to change the “Amounts are tax inclusive” to be unchecked, and set Unit Price as 3,454,545. manager.io still calculated Tax as 390,000.00, it should be 345,454.00 right?. By these data only, I’m sure that the calculation was incorrect, Unit Price + Tax Amount would be 3,935,454.00, not 3,900,000.


.
.
And yet the Average Cost still calculated as 3,510,000.00 not 3,545,455.00 even though the Unit Price in the Payment slip shows 3,545,455.00

Thank you

I cannot produce any of your three results:

  • Tax-inclusive purchase invoice
  • Tax-inclusive payment
  • Tax-exclusive payment

All three approaches give the the correct results in my tests. Two possibilities may be involved:

  • There was a temporary bug that has already been fixed. What version of the software are you using? Try updating to see if the problem is resolved.
  • Your tax code is defined incorrectly. Please post a screen shot of the Edit screen for your PPN 10% Pembelian tax code.
1 Like

Ahhh, the problems seem to be due to incorrect Tax Code settings, I checked the “Flat Rate”, and fill it with a 10% value. After I unchecked the “Flat Rate” all work like normal. Thank you Tut