Implement OAuth2 for email

When I try emailing a sales invoice to a customer, I get this error. I updated to the latest version (19.12.14) and the error persists.
I’m on Windows 10 Pro 64bit. I previously updated Manager on the 7 Jan and have sent several emails successfully since then. Last night, it started doing this to me and restarting Manager didn’t help at all. Seems to do the same for sales orders too.

My conclusion is that it has to do with the fact that Yahoo is removing support for “Less Secure Apps” and mandating OAuth2. In last two weeks I have had to edit the configuration of all my email clients in order to retain access. Yahoo is removing the “Allow apps that use less secure sign in” setting in March. App passwords may be used instead, but I don’t know for how long. It would nice to see OAuth2 email access implemented before it becomes completely mandatory. Thanks. :grinning:

Have you followed this Guidance: https://www.manager.io/guides/22838?

Yes, I’ve solved the problem for the moment, and that’s what I did.
However, as far as I can see, it’s not a permanent solution. Yahoo are regularly tightening their security, and since OAuth2, which they prefer, is available for applications they are likely to further restrict or remove app passwords too. This is something that is going to have to be considered eventually, so I’m putting it out there now.