I get SSL and access my manager without port no


I have installed Server Edition 7 Months ago… I do not know what i have done in the past and how do i setting that i can get my sub-domain pointing to the manager with ssl security and without using the port 8080
xxxxxx.com - xxx sex videos free hd porn Resources and Information. (installed manager 17.3.20)

Now I would like to update to the latest version but I am afraid disturb or make upside down the current setting (ssl and without port). Therefore I have tried to install fresh under new doplet in digitalocean
http://xxx.xxxxxx.com:8080/login (installed manager 17.10.84) and in this new installation i don’t get ssl and i have to access via port 8080

Please advise me on how to update my 17.3.20 version to 17.10.84 without disturb the setting.

Thanks and best regards

You should just be able to replace the installation of Manager on the existing server, and then restart the service. Do you have SSH access?

If DigitalOcean provides a way to do so, you should be able to create a copy of the existing instance (rather than installing fresh on a new one), and try it:

  1. Download latest version:
    wget https://mngr.s3.amazonaws.com/17.10.88/ManagerServer.tar.gz -P /usr/share/manager-server
  2. Untar the downloaded file to replace existing server file:
    tar -xzf /usr/share/manager-server/ManagerServer.tar.gz -C /usr/share/manager-server
  3. Restart the service:
    systemctl restart manager-server

I do this on my AWS server regularly, and have had no issues. The SSL / Port configuration is separate.

1 Like

Hi ShaneAU,

Yes, I do have SSH access.
Thank you for your respond. I had tried and follow 3 steps above and nothing happen. Please advise, thanks

What do you mean by “nothing happen”? Did you try logging in afterwards, to see if it had been updated?

Please post the output of those commands, so I can possibly help further.

1 Like

Yes, after done is still showing the old version.
Bellow is the command (IP address I hide for security)

Found the problem.

Notice that it saved the file as ManagerServer.tar.gz.1 - because you already had a file there from last time, I assume.

If you re-run the unzipping command (tar -xzf …) but put the new file name in there with the .1 at the end, it should work.

And of course, remember to restart the service again after you’ve done that.

Next time you download an update it might be .2 instead, so you’ll need to check what it saves as when you do an update.

Hope this helps. Let us know how you go?

1 Like

Hi ShaneAU,

Great… thank you very much for your advise. It works.