Error on find & recode function

I am using the find and recode and my manager version is 19.10.11. It suddenly throw the following error.

Internal Error

19.10.11 (Server)


System.Collections.Generic.KeyNotFoundException: The given key '054dfae1-c34a-475e-abde-49e0385ffc9a' was not present in the dictionary.
  at System.Collections.Generic.Dictionary`2[TKey,TValue].get_Item (TKey key) [0x0001e] in <285579f54af44a2ca048dad6be20e190>:0 
  at ManagerServer.HttpHandlers.Businesses.Business.ReceiptsAndPayments.FindAndRecodeReceiptsAndPayments.Get () [0x00391] in :0 
  at HttpFramework.HttpApplication.ProcessRequest (HttpFramework.HttpRequest request, HttpFramework.HttpResponse response) [0x000ae] in <5f29c56ab2e046f098756ee11b2d8e0d>:0 
  at ManagerServer.HttpApplication.ProcessRequest (HttpFramework.HttpRequest request, HttpFramework.HttpResponse response) [0x00763] in :0

I put this into the bugs category.

To help with resolution, please explain what you did that triggered this error.

I am using the server version, so I am working on different tabs but not opening same function. I am allocating transactions that are in the suspense account to the correct accounts. As I am going through the suspense account I am identifying transactions with same / similar references, once I identify those, I will then switch to the tab with Find & Recode then search for those transactions and allocate them accordingly.

I then added an account in the chart of account which was open in another tab. I then refreshed the Find & Recode tab so that it can pickup the new account created that is when it gave me the error.

I tried closing the all other tabs and refreshing but nothing is working.

It sounds like you interrupted the Find & Recode process when it was partially complete. And your addition of a new account in the middle of it could very likely have produced the error. I will leave this in the bugs category for now, because @lubos considers anything that generates an error to be a bug.

I suggest, however, you may be able to resume normal operations by logging out from the program completely. (It does not sound like you ever closed all browser windows.) Relaunch your browser, log back in to your Manager installation, and try again. Let us know if that resolves things.

I have tried what you have suggested and it is still throwing the error.

What I have done is to delete the current business and then imported the earlier backup. I am restarting to work with the backup now.

While you await resolution, you can still remove transactions from Suspense by drilling down on that account from the Summary page and editing them individually.

Fixed in the latest version (19.10.21)