So recently I came accros this error…

DocumentSaveException: Exception of type ‘Apitron.PDF.Kit.ErrorHandling.DocumentSaveException’ was thrown.

I can’t send mail or export pdf. And only it happens in one client. I searched the forum with symbols breaking the format of pdf but no luck. And mail address I enter is just correct.

I tried to edit the customer’s invoice details as plain as possible without symbols still the same. I’m using Manager 17.4.60 ad MacOS Sierra.

I think it’s somehow related to 1 client’s entries.

Any help is appreciated.

If this is a new customer, I would delete and re-enter necessary info. If the client has a long history, making that difficult, I would create a new customer, differentiated only with a small name difference and see if things work that way. You could also create a test company and do the same thing. Your problem is almost certainly with a character, possibly a hidden one.

Hi Tut

Unfortunately its one of my oldest customer. I thought about deleting and re-entering the client’s details but I think I’ll loose all of its data… I do not now how to manage it after that.

hidden character? Hmm that I didn’t think about that. I’ll try to clear out the data.

If I delete and re-enter the client, how can I make sure their invoices are not lost

This is the error when I want to export as pdf

DocumentSaveException: Apitron.PDF.Kit.ErrorHandling.DocumentSaveException: Exception of type ‘Apitron.PDF.Kit.ErrorHandling.DocumentSaveException’ was thrown.
at Apitron.PDF.Kit.FlowDocument.Write (System.IO.Stream outputStream, Apitron.PDF.Kit.FixedLayout.Resources.ResourceManager resourceManager, Apitron.PDF.Kit.FixedLayout.PageProperties.PageBoundary boundary, Apitron.PDF.Kit.PdfStandard pdfStandard) [0x0008c] in <728adfd22f494302abfb7751894c81e5>:0
at ManagerServer.PdfConverter.ConvertHtmlToPdf (System.String input, System.IO.Stream output, Apitron.PDF.Kit.FixedLayout.PageProperties.PageBoundary pageBoundary) [0x004e6] in <96ce5e244cdc4e67b50264d98353f7cc>:0
at ManagerServer.HttpHandlers.Pdf.Post () [0x00136] in <96ce5e244cdc4e67b50264d98353f7cc>:0

Just delete the data in one customer field (noting it on paper), click update and does this resolve the issue then re-enter the data and click update and does the issue return - as the problem is only occurring with one client, there is a needle in the haystack somewhere.

Did you attempt the above suggestion of creating a test business and creating this troublesome client within it to see if the situation duplicates itself.

You can’t delete a Customer if there are transactions referenced to them.

Hi Brucanna

I’ll try your suggestions and get back with results here.

Thank you all for help

You can send me your accounting file to and I can try to reproduce the issue.

Hi Lubos

I send you the backup via mail.

Let me know if you need anything else.