Date format not shown properly





i use custom field in sales invoice …i call in custom filed in print formate then show like this with time
how to remove time formate

@hussainiii, you need to explain what your screen shots show and why you think something is not shown properly. No one can guess.

The date of the order includes a time of 12:00:00 AM in the second screenshot however no context is shown

Yes, I understood that, @Patch. Without the necessary context, speculation is pointless. I suspect @hussainiii is showing something from a custom theme, but what? And if it is a custom theme, we would also need to see the code for the theme itself.

He has a custom field of type date which shows the time component. So I suppose the questions are

  • what version of Manager
  • is a custom theme used or the built in theme
  • which screen or export format displays this behaviour

I presume it must be a custom theme, because there is no transaction form that shows “Order No.” twice, and certainly none that follows an “Order No.” label with a date. Nor would any normal display of a custom field have a different label than assigned on the custom field edit screen.

Version is 21.6.9 its is custom theme and use for custom field date in print format. yes problem is for a time format 12:00:00 AM

A search of the forum leads to this thread Problem with date filtering - Manager Forum

You might also try updating to the latest version

Or blanking out the time format in Settings/Date & Number format

As I wrote earlier, you need to show the code for your custom theme.

problem fixed

{{ custom_fields[“Order Date”] | date:“dd/MM/yyyy” }}

1 Like