Bug when selecting Belarusian language

I changed language from default to another and then back.
Since that, the program would not start.
The error message I receive is
System.NullReferenceException…
in Manager.Globalization.LangageInfo.GetTranslatedText(String key)…
Uninstall and reinstall does not solve the problem.
Cannot find any registry values to delete after uninstall (I thought that software trash might be there - but no luck).viber%20image2

Did you reinstall the same download, or download the latest version? v18.4.55 is 9 updates old. There might have been a bug that was immediately fixed. (I don’t know.) At any rate, I suggest trying an update.

Thank you for your prompt reply.
It seems that the update does not solve the problem
mgr-io.

try reinstalling after performing a cache clean and registry errors fix with any third party program like CCleaner.

None of this will help. This is a bug in the program but it’s strange nobody else can reproduce this.

If I buy the paid version (i.e. manager server or manager clavoud) would I get some kind of support, or I would have to wait in the forum for hours, or maybe for days to get a reply, while my firm runs daily?
Is there different support and more personal, if I buy the program?

@sharpdrivetek: if for any program that I install or unistall, I would have to:

  • run ccleaner and repair my registry (all we know that serious problems might occur if you “touch” wrong things in Windows registry)
  • run check disk
  • run defrag
  • run system restore and go back in time
  • or other aggressive solution (such as format my disk)
    then that program is just for a kindergarten.

I am not saying that you suggested all the above, but you could have.

No. Every user gets support the same way. Also, understand that the lack of a solution after only 20 hours does not mean no one is working on your problem. The developer acknowledged a bug after 14 hours. But it can be hard to discover the source of a problem experienced by only one user out of thousands around the world.

Meanwhile, more information from you might help. You said, “I changed language from default to another and then back.” Which languages? Did the program work before that? What modules were enabled?

Since your problem was triggered, according to you, by changing the language preference, did you make entries in either language? If so, which ones, and in what type of transactions? Did you close and relaunch the program in the second language before changing back and encountering the problem?

  • Changed the language from Greek to another (1-2 up or down the Greek, I do not remember).
    Immediately rechanged back to Greek, without adding anything, without doing anything, without making any transaction. Nothing. Just that change and back and voila!
  • The program worked nice before that change.
  • I do not remember what modules were enabled, as I am new to this program. But I am pretty sure more that half of them were enabled.
  • Since the problem was triggered I get ONLY the above error screen and nothing else. The software does not start at all!

if you want to translate the Greek letters in the error (the only part that cannot be understood, as the others are in English), it says “object reference not set to an instance of an object”

It would appear that as a result of this action a file either within Manager or outside Manager has got itself into a knot so the first action is to see if a Manager programme file or a Manager data file is causing the issue. To test this, can you download Manager on to a different computer and then open it and create a test business and do the language swap and see how that works and if all is okay, then transfer the data file across and see if that opens okay.

Because everybody’s computer is different, what happens on one may never happen on any other, also for files outside of Manager I have found using system restore to be very effective as it can reinstate files into the pre-knot status.

It’s installed in my laptop too (another place - not the same IP).
I made the same change back and forth, many times with different languages. Nothing happens. Program works fine.

I do not think that the data file replacement is the issue, as I uninstalled the program, deleted the location, found the registry value (which was empty but could not be deleted).
When reinstalled the program there was another data file, different from the -let’s say- “corrupted” previous one.

Although, I will try the replacement trick and get you posted

When you “uninstalled,” did you delete the application data folder? The corrupted file might be in there. Be careful as you do this, so as to not lose valuable data. Read this Guide first to understand what is in the application data folder: https://guides.manager.io/8394.

Save any actual business data files in a safe place. The rest of them will be recreated if necessary. The goal is to empty the location where Manager is storing data, then reinstall. Then you can import files one at a time to see which triggers the problem. Make sure you note the hexadecimal names of the files, because they are not comprehensible. When you have figured out which file is corrupted, you can isolate and replace it.

Not only deleted it, but also I chose another destination to install (C:\users\user or C:\users or even C:\

Now I’m confused. How did you change the path for the application data folder if you cannot successfully launch the program?

OK.
Uninstall program from control panel > reinstall program > at the step that the installer asks for destination to install > I tried also other destinations as previously described.

Also have tried to delete everything and reinstall at the default destination

@evaggelos, the steps you have taken only address the program itself. The application data folder is a totally separate location specified under Preferences. Most likely, you did not change it from the defaults. It will likely be a hidden file, so you will have to take steps so your operating system displays hidden files. I think you are going to have to find the application data folder.

Okay, this seems to eliminate the Manager programme as being the cause, so we now have to eliminate the Manager data file as being the cause. So we need to copy the .manager (that’s dot manager) file)s to a USB or similar and then see if the laptop computer can open them okay.

Noting that the Manager programme and the Manager data files are located separately, that is, if you uninstall the programme you don’t also uninstall data files.

The data files should be located at C:/users/(user name)/appdata/local/manager unless you have changed the path, otherwise do a windows explorer search for .manager.

Deleted the data file and reinstall it.
Worked perfectly.
But the important is that I managed to reproduce the problem.
I chose another language (Belarussian) and had the same problem again (that seems to had done, because Belarussian is exactly below Greek and probaly pushed it by mistake).

So I did again the same thing and the software crashes with the error System Null reference.
So, be careful, especially those that have a lot of data: DON’T touch that language, at least for the time being.
Maybe the developers will find a solution.

I can reproduce this when selecting Belarusian. I’ve changed the subject of this topic and put it into the Bugs category.

I can reproduce it too but the issue seems to be with WebTranslateIt portal. Until it’s resolved, I’ve removed Belarusian language from the program. So if you upgrade to the latest version (18.4.74), Manager should switch to English if it was set to Belarusian.