Backup causing crash - Mac Desktop Version

Hi, I have tried to follow the instructions regarding backing up. However, whenever I do that, I am given a huge error message, and the the application closes.

I am using Manager 16.7.29
Mac OS X El Capitan 10.11.5

Thank you

Please describe exactly the steps you are following, click by click. If you get error messages, please post a screen shot of them.

Thank you for your reply.
I finish the work in Manager , then at the Summary page, I click Backup ,
once the pop up appears for saving the file, I specify for the file to be
saved on my OneDrive, and it just crashes. I have tried to save it on the
desktop, it also crashes. The error message is huge, and listed below.
Thank you!

System.Net.WebException: Error: ConnectFailure (The requested address is 
not valid in this context) ---> System.Net.Sockets.SocketException: The 
requested address is not valid in this context at 
System.Net.Sockets.Socket.Connect (System.Net.EndPoint remoteEP) 
<0x11b253f20 + 0x00313> in <filename unknown>:0 at 
System.Net.WebConnection.Connect (System.Net.HttpWebRequest request) 
<0x11b24bbe0 + 0x00653> in <filename unknown>:0 --- End of inner exception 
stack trace --- at System.Net.WebClient.DownloadDataInternal (System.Uri 
address, System.Net.WebRequest& request) <0x11b23b480 + 0x00373> in 
<filename unknown>:0 at System.Net.WebClient.DownloadData (System.Uri 
address) <0x11d56f400 + 0x00067> in <filename unknown>:0 at (wrapper 
remoting-invoke-with-check) System.Net.WebClient:DownloadData (System.Uri) 
at ManagerDesktop.Form+<>c__DisplayClass1_1.<CreateMainForm>b__5 
(System.Object o, Eto.Forms.WebViewLoadingEventArgs e) <0x11b1de0d0 + 
0x01515> in <filename unknown>:0 at Eto.PropertyStore.TriggerEvent[T] 
(System.Object key, System.Object sender, Eto.T args) <0x1179c6b00 + 
0x0009f> in <filename unknown>:0 at Eto.Forms.WebView.OnDocumentLoading 
(Eto.Forms.WebViewLoadingEventArgs e) <0x11b1de040 + 0x0004b> in <filename 
unknown>:0 at 
Eto.Forms.WebView+Callback+<OnDocumentLoading>c__AnonStorey2.<>m__0 () 
<0x11b1de010 + 0x0001e> in <filename unknown>:0 at Eto.Platform.Invoke 
(System.Action action) <0x1193b7c30 + 0x00036> in <filename unknown>:0 at 
Eto.Forms.WebView+Callback.OnDocumentLoading (Eto.Forms.WebView widget, 
Eto.Forms.WebViewLoadingEventArgs e) <0x11b1dde60 + 0x0016f> in <filename 
unknown>:0 at 
Eto.Mac.Forms.Controls.WebViewHandler.HandleDecidePolicyForNavigation 
(System.Object sender, WebKit.WebNavigationPolicyEventArgs e) <0x11b1dcce0 
+ 0x001e0> in <filename unknown>:0 at 
WebKit.WebView+_WebPolicyDelegate.DecidePolicyForNavigation (WebKit.WebView 
webView, Foundation.NSDictionary actionInformation, Foundation.NSUrlRequest 
request, WebKit.WebFrame frame, Foundation.NSObject decisionToken) 
<0x11b1dc9a0 + 0x00098> in <filename unknown>:0 at (wrapper 
managed-to-native) AppKit.NSApplication:NSApplicationMain (int,string[]) at 
AppKit.NSApplication.Main (System.String[] args) <0x1193b71b0 + 0x000c3> in 
<filename unknown>:0 at Eto.Mac.Forms.ApplicationHandler.Run () 
<0x1193b6e60 + 0x000f7> in <filename unknown>:0 at 
Eto.Forms.Application.Run (Eto.Forms.Form mainForm) <0x1193a0900 + 0x00207> 
in <filename unknown>:0 at ManagerDesktop.Form.Show () <0x1179b9480 + 
0x0018f> in <filename unknown>:0 at ManagerDesktop.Program.Main 
(System.String[] args) <0x10f996e40 + 0x000b0> in <filename unknown>:0 On

Are you using the desktop version? Obviously you are having web problems. Can you try backing up to a local drive like a USB flash drive?

I am using the desktop version, I was trying to save it to the local
folder, not online. Nevertheless the problem persists. Please kindly
advise. Thank you!

Just in case its a problem with the installation, why don’t you uninstall the programme and re-do the download. The Manager programme files are stored in a different location to the data files so they should remain unaffected and should auto re-load into the re-installation.

As extra protection, do a manual back-up of the data file location

In your original post, you said you were trying to save the backup to your OneDrive, which is a cloud-based service by Microsoft. So why do you think this is a local folder and not online? And why are you using OneDrive at all if you’re a Mac user?

On a Windows machine OneDrive is a local folder, this is where you first put the files that you want backed up - then in the background OneDrive duplicates those files to the cloud in exactly the same way as Dropbox does. I don’t think you can send a file directly to cloud OneDrive via online.

All my active files (i.e. Manger etc) are placed in either the OneDrive or Dropbox local folders, this way they are always automatically backed up without doing a back up.

If OneDrive is not available as a Mac feature - perhaps this is why the backups are crashing - squeezing a Mac file into a Windows folder.

Note - OneDrive’s 15GB of free storage is being reduced to only 5GB free from Aug 10.

Brucanna, thank you very much for your advice. I will try to uninstall and
reinstall. I was trying to do exactly the same as you outlined, saving it
under the Dropbox folder on my computer, and wanting it to be synced to the
online account. However, it keeps crashing. I will try again. Cheers.

Hi Tut, unfortunately, even with uninstall and reinstall it is giving me
the same error message after force closing the programme. Not sure why it
is trying to do a online backup when it is in fact a desktop version. Is it
something I should raise with technical support? Thanks.

This forum is the source of technical support.

If you are using Dropbox or OneDrive, those are both online resources, regardless of the fact that your edition may be Desktop. That raises all kinds of questions. Did you modify the default installation location to install Manager anywhere from where it automatically wants to be? Are you somehow trying to run the application from a remote drive? (That’s a recipe for problems.)

You haven’t responded yet to my original suggestion that you try to back up to a local drive, such as a USB flash drive. You just keep bringing up additional details that point to the fact that you are backing up remotely, and possibly not even to storage locations with real-time access, depending on how preferences are set.

So go back to the beginning:

  1. Are you installing Manager per instructions in your Applications folder on your Mac?

  2. Do you actually have accounting data you need to access, or have you only been experimenting prior to adopting the program? If you do, click on About Manager to see what folder it is in. Make note of this folder.

  3. Do a clean installation in the default location, then use the Add Business button to choose the Import option and navigate to the folder from @2 above.

  4. If you don’t have any real data yet, create some test entries using your clean installation and back up to a LOCAL drive. Both the test entries and the backup location can be deleted or changed later.

  5. If you have trouble with these steps, post screen shots of the results. If not, then you can start experimenting with other backup locations. If you encounter problems, post screenshots of those results and descriptions of exactly what you’ve done that produces the errors.

I can say without fear of contradiction that your problem is caused by something you’ve done or a configuration of your system, not a bug in Manager. Many, many users have the same setup you do and don’t have problems. You may have firewall issues, network problems, etc. Until we’ve eliminated the easier things, there is no point, though, in progressing to more arcane troubleshooting.

You don’t need to be online to use either Dropbox or OneDrive functionality . You could work all day offline and then go online just to allow OneDrive/Dropbox to sync their respective folders and then go offline again.

Thank you both for your assistance. I have done what you have mentioned, the problem persists. I will try another programme. Cheers.

Yes, @Brucanna, I realize that. But depending on how one has either of those resources set up, there could be complications related to the fact that they are cloud-based. I was trying to give advice that would isolate the problem from web issues. But @RobinY doesn’t seem to want to share details, only to restate that a problem exists that others don’t experience.

@RobinY, try the latest version (16.7.38). It could fix the issue.

Thank you Lubos for your suggestion, the version I am using is 16.7.40, and
I have searched around but could not find 16.7.38. Thanks.

This is because there has been 2 new versions since my last post.

Anyway, do you still experience this issue in the latest version (16.7.40)?

Yes, that is the only version I have used on my Mac. No worries, I am using
the windows version on my laptop, which works fine. Thanks.

But version 16.7.40 shouldn’t be producing that error message anymore. When you are on Mac and click About Manager, does it say version 16.7.40?

Yes it does say that. However, I have tried again just now. It is
working fine. Thanks lubos.